
�

Rosetta Stone® 
Floating License

Network Installation Guide

S
ta

rt
 H

e
reThis Guide Includes:�

Installing the Floating License Manager (Server)........... 1

Activating the Floating License........................................ 1

Storing Rosetta Stone Language Data............................ 2

Installing the Student Management System................... 2

Setting Up the SMS........................................................... 3

Installing to Workstations and Configuring................... 4

Reference Section............................................................. 5



Need Help?  
Online Knowledge Base:  
www.RosettaStone.com/support 
Live Technical Support: 1-800-280-8172
Weekdays, 9am–8pm (Eastern Time)

Rosetta Stone® Network Installation Guide

Activating the  
Floating License

Insert the Network Application CD-ROM. 
Select Install to begin and follow the 
prompts to the Select Install Type Screen.
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2 Select Floating License Manager  
(Server). Click Next and continue  
through installation. 

Installing the 
Floating License Manager 

Floating Licenses allow a limited number of users to access Rosetta Stone from anywhere on 
a network. Your 16-digit License Activation Code is applied to the inside of the Install Materials 
folder that holds the CD-ROMs.

IMPORTANT: Do not install licenses through a remote connection. All license activation must 
be done when physically located at the host computer. Do not install licenses to a test server or 
workstation. Once a license is installed, it cannot be re-used or moved without assistance from 
Technical Support. 

The Student Management System (SMS) is an optional component that can be used to track 
student progress. See the Student Management System Manual for more information.

Floating License Installation

For options, see Floating Licenses in the 
Reference Section, page 6

Note:

Enter your 16-digit License Activation Code 
(LAC) and the number of concurrent users 
associated with the LAC on the Floating 
License Activation screen. Click Next. 
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If a proxy configuration is required to 
access the Internet, check the “I need to 
use a proxy server to access the Internet” 
checkbox and enter the IP address and 
port number for your proxy server. You 
may use either the hostname or the 
IP address of the proxy server. If your 
network does not use a proxy server,  
leave the field blank. Click Save.
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Enter the IP address and port number of 
the Floating License Server and click OK.3 3 Share the folder. (For Macintosh, set the 

folder as a share point.) Set the sharing 
permission for the folder and contents to 
Read Only for all users.

Record the IP address and port number 
entered as they will need to be entered on 
each workstation running Rosetta Stone.

Tip:  

When the LAC is activated successfully, you 
will be notified as to where the license file 
has been saved. Click Activate another 
LAC to enter another activation code or 
Exit to complete installation.

Insert the Level 1, 2, or 3 Rosetta Stone  
Language Data CD-ROM into the CD-ROM 
drive on the server. (For Windows, the 
Autoplay application on the Language 
Data CD-ROM will start automatically.  
Click Quit to exit.)
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Copy the Language Data to the server.

Windows server: Create a folder for each 
language and copy the entire contents 
of the language disc(s) into the folder 
overwriting any duplicate files.

Macintosh server: Create a separate folder 
for each language disc. Copy the entire  
contents of each language disc into its 
appropriate folder.
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In Windows Explorer, right click on  
the CD-ROM icon and select Explore  
to access the contents.

Tip: 

For more setup options, see Storing 
Language Data in the Reference  
Section, page 6.

Tip: 

Storing Rosetta Stone 
Language Data

Activation may take some time. Do not  
click Cancel while activitation is in progress.

Note:
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Insert the Student Management System (SMS) 
CD-ROM into the server computer. 

Windows: When the dialog box appears,  
click Next to start the installation.

Macintosh: Double-click SMS Installer. 

Click Next at each prompt.
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2 Leave Run SMS as Service selected. 

Windows: Click Next. Click Yes to add desktop icons.

Installing the Student 
Management System (SMS)

To install the Student Management System 
(SMS), continue to Section D. If you are not 
installing the SMS, skip to Section F.

Note:

Macintosh: Click Install.

3 If you have more than one IP address 
on your computer, the following screen 
appears during installation: 

Select an IP address from the pull-down 
menu to direct the SMS Installer to run  
the SMS Server on that IP address.



4Windows: When you reach the  
Finished screen, leave Run  
the SMS Administrator  
selected and click Close.

Macintosh: When your installation  
is complete, go to Applications  
➔ SMS 3.x and double-click  
on Administrator.

In the SMS Administrator screen, log 
in with Username: admin and Password: 
password. Click Log In.
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6 Click No when prompted to make a back-
up of the database. After your students 
start working, click Yes once a week. The 
database backup is created as a date- and 
time-stamped file in the SMS folder on 
your hard drive.

Setting Up the SMS

1 In the Menu Bar, select File ➔ Setup 
Wizard. With Set Up Instructors 
selected, click Next.

2 To create a new Instructor, click Add 
New Instructor and enter the Instructor 
information. To allow the Instructor to 
add Students and Instructors, check the 
box to Grant Administrator Access. 
Click Save and click Next.
Administrator Access should be granted 
sparingly because it locks the SMS for editing.

Note:

If you have installed the SMS, follow these 
steps for the initial set up of the SMS. You can 
return to the Wizard at any time to add more 
Instructors or Students.

Note:
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Insert the Network Application CD-ROM.

Windows: select Install. 

Macintosh: select Rosetta Stone Installer 
OS X then Install. 

Follow the prompts to the Select Install  
Type Screen.

1

2 Select Floating License Application  
(Workstation). Click Next (Windows) or 
Install (Macintosh) to continue through 
installation.

Installing to Workstations  
and Configuring

If data is shared on multiple servers or 
folders, add multiple paths here. Click 
Verify All to ensure the workstation can 
communicate to all the data shares. Click 
Save to save your changes.

Network Configuration Utility. 
On the Data Location Screen, enter 
the path to the Language Data or click 
Browse to find the shared Rosetta Stone 
Language Data on the network.
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3 If you installed the SMS, click on Find  
SMS Server(s) and select the server.

If you did not install the SMS, close  
this window.

3 To create a new class, click Add New 
Class. Fill in the Class Name, select  
the Language, select a class from the 
Copy Class list and select a Default 
Track to use for the class. Click Save  
and click Next.

4 Click Add New Student. Fill in  
the student’s Name, Username and  
Password and click Save. A Password  
is recommended but not required. 

Click to add a student.

6 The student moves to Enrolled Students. 
Click Finished. The Setup Wizard closes 
and the SMS Administrator screen returns. 
Close this screen.
On each Instructor workstation, install the 
SMS as Administrator Only. Instructors can 
monitor their own classes and students.

Tip: 

5 Select the Instructor and Class, and 
choose a Track to Enroll Student(s) in 
Track. Select the student in the Available 
Students list. Click >> to enroll the student. 
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• �Typically, the Floating License Manager 
and the Student Management System are 
installed to run as a service on the server 
machine so that these components run 
continuously in the background. 

• �The Floating License Manager requires a 
Windows machine or server with a static 
IP address on the network accessible via 
TCP/IP by all workstations. 

• �The client machines will access the 
Floating License Manager and the SMS 
via the IP address of the server or host 
machine. The client machines will find 
the language data via a path entered 
during the client install. 

If multiple License Servers are setup (see 
Floating Licenses in the Reference section), 
add the IP addresses and port numbers 
here. Click Verify All to ensure the work-
station can communicate to all License 
Servers. Click Save to save your changes.

Use the same IP address and port number 
that was used in step B3.

Note:

On the License Server Screen, enter the IP 
address and port number of the computer 
running the Floating License Manager.
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• �System requirements – For current system 
requirements go to www.RosettaStone.com, 
click Support, then System Requirements.

• �A one-time Internet connection is required  
to activate the licenses on the machine(s) 
hosting the Floating License Manager.

• �A printed SMS manual is include with  
your materials. This and other manuals  
are available at www.RosettaStone.com.  
From the homepage, click Support, then  
click Downloads.

Important tips:

Reference Section

If you are not using the SMS, click Clear and 
Save. To return to this screen, choose: 

Windows: Start ➔ Programs ➔ Rosetta 
Stone ➔ [version number] ➔ 
Administrator Tools ➔ Network 
Configuration Utility

Macintosh: Applications ➔ Rosetta 
Stone ➔ [version number] ➔ Network 
Configuration Utility

Tip: 

The numbers above are examples, your 
unique IP address and port number will differ.

Note:

The Student Management System Screen 
displays the IP address and port number of 
the computer where you have installed the 
SMS Server. Click Save.

If these numbers do not appear, enter the 
IP address and port number. To find the 
IP address and port number of the SMS 
Server, select SMS Configuration from 
the Student Management System Program 
menu (Windows) or Application folder 
Macintosh. Click Save.

5
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A Floating License allows for a fixed 
number of concurrent users to access 
Rosetta Stone at the same time. The 
Floating Workstation Application may 
be installed on any machine connected 
to the network. Floating licenses are not 
attached to a specific machine, but rather 
to a specific number of users, hence they 
“float” on the network. The Floating 
License Manager automatically controls 
licenses on the network. 

Number of Floating License
You may install the Rosetta Stone 
Application on an unlimited number of  
workstations, however, the number of 
concurrent users will be limited to the 
amount of licenses purchased. The number 
of concurrent users is listed with your 
License Activation Code (LAC), inside 
the Installation Materials folder. The 
number of concurrent users is the same 
as the number of licenses purchased for a 
particular License Activation Code.
Example: Your institution purchased 25 
Rosetta Stone licenses for Spanish Level 1. 
Your institution has two computer labs with  
25 computers in each lab. Your supervisor 
would like all machines in both labs to be 
able to access Rosetta Stone. Therefore, 

Floating Licenses

you should install the Rosetta Stone 
application on all 50 machines. However, 
only 25 computers will be able to use 
Rosetta Stone Spanish Level 1 at the  
same time. 

Installing Floating License(s) on  
Multiple Servers
You may divide your floating licenses 
among several servers if you choose. 
Simply install the Floating License Manager 
(Server) on multiple machines and activate 
only the number of licenses you would like 
that server to control.
Example: You are a system administrator 
for an institution with three campuses. 
You are in charge of Campus X. Your 
institution purchased a total of 500 Rosetta 
Stone Spanish Level 1 floating licenses. 
Your supervisor would like Campus X to 
have 300 licenses, Campus Y to have 150 
licenses, and Campus Z to have 50 licenses. 
As system administrator for Campus X, 
you would enter 300 in the Number of 
concurrent users field. The license server 
at Campus X would manage those 300 
Rosetta Stone Spanish Level 1 licenses.

• �The Rosetta Stone Application and SMS  
cannot be installed to a Novell or Linux 
server and do not run through Citrix, 
Thin Clients or Terminal Server.

• �Client installation (Instructor or Student 
Workstations): The client install is best  
done at each client workstation. However,  
it is possible to install the Client version 
to the server, configure it properly with 
all the correct IP addresses and data 
path(s), run it once, then push it (the 
Rosetta Stone folder and the desktop 
shortcut) out to the client workstation. 
QuickTime should be installed on student 
workstations. JAVA is required on 
Instructor workstations to run the  
SMS Administrator.

On a Server
The language data is normally stored in a 
shared folder with read-only permissions 
on a server.
Note: You may install the language data on 
any file server that can be accessed by the 
client workstations. 

Workstations with Language Data  
on a Server
Rosetta Stone will identify language data  
if it is stored at the root of any mapped 
drive or mounted volume. You will not  
need to specify the data paths in the  
Network Configuration Utility if language  
data is stored at the root of a physical or  
logical drive letter/mapped drive (Windows) 
or mounted volume (Macintosh). 

Storing Language Data

6
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License Activation
 I get a message that says: “Activation 
failed: There are not enough licenses 
available to fulfill your request.” 
You have either attemped to activate more 
licenses than were purchased, or all of 
your licenses have already been activated. 
Refer to the license information applied 
to the inside of the Installation Materials 
folder to find out how many licenses were 
purchased.

Unsuccessful License Activation
Make sure that your Internet connection 
is working and try activating the license 
again. If unsuccessful after a third time, 
click Exit and contact Product Support at  
http://www.RosettaStone.com/support

I get a message “Error 4146.”
It may be caused by an invalid URL or a 
lack of Internet connection, an improperly 
configured proxy server or a permissions 
restriction.

I get a message “Error 4165.”
Is the machine off-line? Establish 
connection to ISP and try again.

We are using other FLEXnet licensed 
products.
You may want to visit  
Macrovision’s support website at  
http://www.macrovision.com.

Troubleshooting

Floating License Manager
I have the Floating License Manager 
running and I want to activate another 
license. 

On the computer where the Floating 
License Manager is installed, go to the 
Start ➔ Programs ➔ Rosetta Stone ➔ 
[version number] ➔ Administrative Tools 
shortcut and launch the Floating License 
Activation Module. 

Click Activate another License to add 
another license to your network. 

Choose: Start ➔ Programs ➔ 

Rosetta Stone ➔ [version number] 
➔ Administrative Tools ➔ License 
Manager Tools. Click the Start/Stop/
ReRead tab. Click on the ReRead License 
File button. For more information about 
available licenses, click the server status 
tab. Click Perform Status Enquiry.

The license server will now re-read the 
newly activated license.

When I restart my computer, the floating 
license server is no longer running.
See Configuring the License Server  
as a Windows Service on page 8.

I started my Floating License Manager, but 
it is not working.

1. �Do you have a valid license file?  
If license activation was not successful, 
the Floating License Manager will not 
work. There must be a valid license file 
in the Licenses folder in your installation 
directory in order for the Floating 
License Manager to run. The default 
path is C:/Program Files/RosettaStone/
Licenses. 
If you specified a port to use, be sure 
that no other applications are using it. 

If the language data is not stored at the 
root level of a logical or physical drive, 
you will need to specify the data paths 
in the Network Configuration Utility. See 
Network Configuration Utility in Step 
F4 of the installation section of this guide. 
Note: For Macintosh environments, make 
sure you set the workstations to mount  
the server containing the language data  
at startup.
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Configuring the License 
Server as a Windows Service

Manually Starting the License Server  
as a Service

1. �Choose Start ➔ Programs ➔  

Rosetta Stone ➔ [version number] ➔ 
Administrative Tools ➔  

License Manager Tools. 

2. �Have you made changes to your  
license file?  
The only changes you are able to make 
are changing the IP address and port 
number on the SERVER line. If you are  
running a FLEXnet license server for  
additional products (other than Rosetta 
Stone) you may also change the VENDOR 
line in your license file. If you have made 
any other changes to your license file it 
is no longer valid.

3. �Have you changed your hardware?  
If you have changed your hardware  
(hard drive, network card, etc.), you  
may need to re-host. See To Re-host  
a License, below.

Floating License Workstations
I get a “number of licensed users has 
already been reached” error message.
The maximum number of concurrent  
users your license allows has been reached. 
Wait until another user logs out. The 
Rosetta Stone Network Application will 
time out after ten minutes of inactivity 
from any one licensed user.

Normally, the License Server runs in the 
background as a service. In case the service 
is stopped, you can restart it manually.

3. �Click on the Start Server button to  
start the service named Rosetta Stone 
License Server. 

4. �Click on the ReRead License File button.

Running the Service Automatically

1. Click the Config Services tab.

2. Check the Use Service box.

3. �Check the Start Server at Power Up  
box. The license server will now auto-
matically start when the machine  
is restarted.

4. �Click Save Service.

If you need to move a license to a new 
machine/server, or have determined 
through troubleshooting that a re-host  
is necessary, you may need to contact  
Product Support at  
http://www.RosettaStone.com/support 
Have the Hostid ready.

How to Find the Hostid 

1. �Select Start ➔ Run.
2. Type cmd and click OK.
3. �Type ipconfig/all after the prompt. 
4. Press Enter.
5. ��The hostid is the Physical Address.

To Re-host a License

2. Click the Start/Stop/Reread tab.
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To Uninstall for Windows
Windows users have three options for 
uninstalling the program:

Option 1
�Click the Uninstall Rosetta Stone  
button on the Autorun screen.

Option 2
�Click Start ➔ Programs ➔ Rosetta Stone 
➔ [version number] ➔ Adminstrative 
Tools ➔ Uninstall Rosetta Stone ➔ 

[version number].

Option 3
• Click on Start in the Windows task bar.
• Select Settings.
• Click on Control Panel.
• Double-click on Add/Remove Programs.
• Select Rosetta Stone [version number].
• Click Remove.

To Uninstall for Macintosh  
(Application Only)
Drag the Rosetta Stone folder into the trash. 
Be sure to throw away any aliases you may 
have created.

Uninstalling the Program

Application
The program that runs the Rosetta Stone 
language-learning interface. 

Floating license
A license that authorizes use of Rosetta 
Stone products on a network. The product 
can be installed on any number of work- 
stations connected to the network. The 
number of concurrent users is limited 
by the Floating License Manager, which 
counts each license. 

Floating License Activation Module
An administrative tool that creates the 
license files during activation.

Floating License Manager (Server)
An application that automatically controls 
licenses on the network.

Glossary of Terms 

Language Data CD-ROM
The language information component 
of the Rosetta Stone program. This 
information is on a separate disc from 
the application. The language data can 
be stored either on the hard drive of the 
computer where the application is installed 
or on a server on the network.

License
The legal right to use a Rosetta Stone 
product. 

License Activation Code (LAC)
The 16-digit code that is used to activate 
a license file. The LAC is located inside the 
Installation Materials folder that holds the 
CD-ROMs.

License file
A file in the Licenses folder that contains  
the activated license information.

Network Application CD-ROM
The disc which contains the application 
program and FLEXnet licensing software.  
This is a separate disc from the Language 
Data CD-ROM. 

Network Configuration Utility
A tool that contains the IP addresses and 
data paths needed by the client machine.

Student Management System (SMS)
A component that allows Instructors to 
control and monitor student study of  
Rosetta Stone.

Workstation
A computer where a user can access  
Rosetta Stone. 
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