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Rosetta Stone® Network Installation Guide
Node-Locked Licenses allow users to access Rosetta Stone on a limited number of licensed  
computers. Your 16-digit License Activation Code is applied to the inside of the Installation  
Materials folder that holds the CD-ROMs.

IMPORTANT: Do not install licenses through a remote connection. All license activation  
must be done when physically located at the workstation. Do not install licenses to a test 
workstation. Once a license is installed, it cannot be re-used or moved without assistance  
from Technical Support. 

The Student Management System (SMS) is an optional component that can be used to  
track student progress. See the Student Management System Manual for more information.

Insert the Level 1, 2, or 3 Rosetta Stone 
Language Data CD-ROM into the CD-ROM  
drive on a server. (For Windows, the 
Autoplay application on the Language 
Data CD-ROM will start automatically.  
Click Quit to exit.) 
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In Windows Explorer, right click on 
the CD-ROM icon and select Explore 
to access the contents.

Tip: 

For more setup options, see Storing 
Language Data in the Reference Section, 
page 6.

Tip: 

Storing Rosetta Stone 
Language Data

3 Share the folder. (For Macintosh, set the 
folder as a share point.) Set the sharing 
permission for the folder and contents  
to Read Only for all users.

2Copy the Language Data to server:

Windows server: Create a folder for each 
language and copy the entire contents 
of the Language Data CD-ROM  
into the folder overwriting any 
duplicate files.

Macintosh server: Create a separate folder 
for each Language Data CD-ROM.  
Copy the entire contents of each 
Language Data CD-ROM into its 
appropriate folder.

Node-Locked License Installation

Need Help?  
Online Knowledge Base:  
www.RosettaStone.com/support 
Live Technical Support: 1-800-280-8172
Weekdays, 9am–8pm (Eastern Time)

To install the Student Management System 
(SMS), continue to Section B. If you are not 
installing the SMS, skip to Section D.

Note:
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Installing the Student 
Management System (SMS)

Insert the SMS CD-ROM into the server 
computer. 

Windows: When the dialog box appears,  
click Next to start the installation.

Macintosh: Double-click SMS Installer.  
Click Next at each prompt.
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4 Windows: When you reach the  
Finished screen, leave Run the  
SMS Administrator selected  
 and click Close.

Macintosh: When your installation  
is complete, go to Applications 
➔ SMS 3.x and double-click on 
Administrator.

In the SMS Administrator screen, log in 
with Username: admin and Password:  
password. Click Log In.
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6 Click No when prompted to make a back-
up of the database. After your students 
start working, click Yes once a week. The 
database backup is created as a date- and 
time-stamped file in the SMS folder on 
your hard drive.

2 Leave Run SMS as Service selected. 

Windows: Click Next. Click Yes to add  
desktop icons.

Macintosh: Click Install.

Select an IP address from the pull-down 
menu to direct the SMS Installer to run  
the SMS Server on that IP address.

3 If you have more than one IP address 
on your computer, the following screen 
appears during installation: 
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4 Click Add New Student. Fill in the  
student’s Name, Username and Password  
and click Save. A Password is recommended 
but not required. 

Click to add a student.

6 The student moves to Enrolled Students. 
Click Finished. The Setup Wizard closes 
and the SMS Administrator screen returns. 
Close this screen.

3 To create a new class, click Add New 
Class. Fill in the Class Name, select the 
Language, select a class from the Copy 
Class list and select a Default Track to use 
for the class. Click Save and click Next.

On each Instructor workstation, install the 
SMS as Administrator Only. Instructors can 
monitor their own classes and students.

Tip: 

2 To create a new Instructor, click Add 
New Instructor and enter the Instructor 
information.

To allow the Instructor to add Students 
and Instructors, check the box to Grant 
Administrator Access. Click Save and  
click Next.

Administrator Access should be granted 
sparingly because it locks the SMS  
for editing.

Note:

5 Select the Instructor and Class, and choose 
a Track to Enroll Student(s) in Track. Select 
the student in the Available Students list. 
Click >> to enroll the student. 

1 In the Menu Bar, select File ➔ Setup Wizard. 
With Set Up Instructors selected, click Next.

Setting Up the SMS

If you have installed the SMS, follow 
these steps for the initial set up of the 
SMS. You can return to the Wizard at any 
time to add more Instructors or Students.

Note:
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You will need the 16-digit License Activation 
Code from the inside of the Installation 
Materials folder which holds the CD-ROMs.

To activate your license, the workstation 
must have a one-time Internet connection. 
Your license will be locked to the workstation. 
Install the program on the computer that  
you want to run Rosetta Stone.

1Enter your 16-digit License Activation 
Code (LAC) on the Node-Locked License 
Activation Screen. Click Next.

2 Select Node-Locked Application 
(Workstation). Click Next (Windows)  
or Install (Macintosh) and continue 
through installation.

Activating the
Node-Locked LicenseInstalling Rosetta Stone

3 If you installed the SMS, click on Find SMS 
Server(s) and select the server. If you did 
not install the SMS, close this window.

Insert the Network Application CD-ROM.

Windows: select Install. 

Macintosh: select Rosetta Stone Installer  
OS X then Install. 

Follow the prompts to the Select Install 
Type Screen.
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3When the LAC is activated successfully, 
you will be notified as to where the 
license file has been saved. Click Activate 
another LAC if you wish to enter another 
activation code or Exit to complete the 
installation process. 

Network Configuration Utility  
On the Data Location Screen, enter 
the path to the Language Data or click 
Browse to find the shared Rosetta Stone 
Language Data on the network. If data is 
shared on multiple servers or folders, add 
multiple paths here. Click Verify All to 
ensure the workstation can communicate 
to all the data shares. Click Save to save 
your changes.
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Activation may take some time. Do not click 
Cancel while activation is in progress.

Note:

If a proxy configuration is required to 
access the Internet, check the “I need to 
use a proxy server to access the Internet” 
checkbox and enter the IP address and 
port number for your proxy server. You 
may use either the hostname or the IP  
address of the proxy server. If your 
network does not use a proxy server,  
leave the field blank. Click Save.
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• �System requirements – For current system 
requirements, go to www.RosettaStone.com,  
click Support, and click System Requirements.

• �Typically, the Student Management  
System is installed to run as a service on  
the server machine so that the SMS server  
runs continuously in the background. 

• �The Network Application CD must be  
installed to each client machine one at  
a time. Each installation will require an  
Internet connection to activate the license  
tied to the machine.

• �The Rosetta Stone Application and SMS  
cannot be installed to a Novell or Linux server,  
and do not run through Citrix, Thin Clients or 
Terminal Server. 

• �A printed SMS manual is included with  
your materials. This and other manuals  
are available at www.RosettaStone.com.  
From the homepage, click Support, then  
click Downloads.

Important tips:

With a Node-Locked License, the licenses 
are attached, or locked, to specific 
computer workstations. This allows for 
an unlimited number of users to access 
Rosetta Stone on a limited number of 
licensed workstations. Workstations with a 
Node-Locked license can run Rosetta Stone 
while disconnected from the network. 
Node-Locked Licenses are required for 
Mac-only networks. 

You will need to install the Rosetta Stone 
application ONLY on the number of 
workstations, for which you have licenses. 
Once installed, Rosetta Stone will only be 
accessible on those specific computers. 
These workstations must have a one-time 
Internet connection for license activation.
Example: Your institution purchased five 
Rosetta Stone Spanish Level 1 licenses. Your 
institution has 20 computers in a computer 
lab. Your supervisor would like you to 
install Rosetta Stone on five computers in 
the lab. An unlimited amount of users can 
access the Rosetta Stone, but only from 
those five computers.

Node-Locked Licenses

Reference Section

192 168 1 1

8081

The numbers above are examples, your 
unique IP address and port number will differ.

Note:

Tip:

If you are not using the SMS, click Clear 
and Save. To return to this screen, choose 

Windows: Start ➔ Programs ➔ Rosetta 
Stone ➔ [version number] ➔ 
Administrator Tools ➔ Network 
Configuration Utility.

Macintosh: Applications ➔ Rosetta 
Stone ➔ [version number]  ➔ 

Network Configuration Utility.

To find the IP address and port  
number of the SMS Server, select  
SMS Configuration from the  
Student Management System  
Program menu (Windows) or  
Applications folder (Macintosh).

Tip: 
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On the Student Management System 
Screen, the IP address and port number of 
the SMS Server appear if SMS is installed. If 
needed, enter the IP address and port and 
click Save.
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Storing Language Data

I get a message that says: “Activation failed: 
There are not enough licenses available to 
fulfill your request.” 
You have either attemped to activate more 
licenses than were purchased, or all of your 
licenses have already been activated. Refer 
to the information applied to the inside of 
the Installation Materials folder to find out 
how many licenses were purchased.

Unsuccessful License Activation
Make sure that your Internet connection is 
working and try activating the license again. 
If unsuccessful after a third time, click Exit 
and contact Product Support at  
http://www.RosettaStone.com/support

I get a message “Error 4146.”
It may be caused by an invalid URL or a 
lack of Internet connection, an improperly 
configured proxy server, or a permissions 
restriction.

I get a message “Error 4165.”
Is the machine off-line? Establish connection 
to your ISP and try again.

My license worked, but now it doesn’t. 
1. �Have you made changes to your  

license file?  
Node-locked license files may not  
be edited or copied to another computer.

2. �Have you changed your hardware?  
If you have changed your hardware 
(hard drive, network card, etc.), you may 
need to re-host. See How to Re-host a 
License in the following section.

I have a node-locked workstation running 
and I want to activate another license for 
a different language or level on the same 
computer.

Windows: Go to the Start ➔ Programs ➔ 
Rosetta Stone ➔ [version number] ➔ 

Administrative Tools shortcut and 
launch the Node-Locked License 
Activation Module.

Macintosh: Applications ➔ Rosetta Stone 
➔ [version number] ➔ Node-Locked 
Activation Module. 

Troubleshooting

On a Server
The language data is normally stored in a 
shared folder with read-only permissions  
on a server.
Note: You may install the language data  
on any file server that can be accessed by 
the client workstations. 

Workstations with Language Data  
on a Server
Rosetta Stone will identify language data  
if it is stored at the root of any mapped 
drive or mounted volume. You will not  
need to specify the data paths in the 
Network Configuration Utility if language 
data is stored at the root of a physical or 
logical drive letter/mapped drive (Windows) 
or mounted volume (Macintosh). 

If the language data is not stored at the 
root level of a logical or physical drive, 
you will need to specify the data paths 
in the Network Configuration Utility. See 
Network Configuration Utility in Step  
E4 of the installation section of this guide. 
Note: For Macintosh environments, make 
sure you set the workstations to mount  
the server containing the language data  
at startup.

On Workstations with Language Data 
on the Local Hard Drive (off network) 
The language data can also be copied to 
the hard drive of individual client machines. 
You will need to specify the data paths 
in the Network Configuration Utility. See 
Network Configuration Utility in Step  
E4 of the installation section of this guide. 
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How to Re-host a License

If the hardware of your workstation has 
been changed, damaged or you wish to 
move a license to a different workstation, 
you may need to re-host the license on 
another machine.

This is best done at the workstation to  
be re-hosted.

To re-host a license on another machine, 
first you must return the license, then  
re-host the license. You will need: 

• the License Activation Code (LAC) 
• the Hostid of the machine to return 
• the Hostid of the machine to re-host 
• an Internet connection.

How to Find the Hostid 

Windows:
1. Select Start ➔ Run
2. Type cmd and click OK.
3. Type ipconfig/all after the prompt. 
4. Press Enter.
5. �The hostid is the Physical Address.

Macintosh: Select Apple Icon ➔ About This 
Mac ➔ More Information ➔ Network ➔ 
Ethernet Address.

Returning a License
Go to http://licensing.rosettastone.com

1. �Enter the LAC in the License 
Activation Code field. Click Login.

2. Select Return Licenses.

3. �Enter the hostid of the machine to 
return in the Hostid field or check the 
box by the item to be returned. Scroll 
down and click Return.

4. �Confirm your selection for return by  
clicking Confirm.

Re-hosting the License

1. �Select the product to re-host or check 
the box by the item you would like to 
re-host. 

2. �Select the hostid type in the Node-
locked Hostid Type field. Usually 
Ethernet should be selected.

3. �Enter the hostid of the machine to re-
host in the Node-locked Hostid field. 

Click Activate another License to 
add another license to this computer. 
See Section A if you are adding a new 
language or level to the network. Then 
see Step E4 to update the workstation to 
reference the new Language Data location.

We are using other FLEXnet licensed 
products.
You may want to visit  
Macrovision’s support website at  
http://www.macrovision.com.
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To Uninstall for Windows
Windows users have three options for 
uninstalling the program:

Option 1
Click the Uninstall Rosetta Stone 
button on the Autorun screen.

Option 2
Click Start ➔ Programs ➔ Rosetta 
Stone ➔ [version number] ➔ 
Adminstrative Tools ➔ Uninstall 
Rosetta Stone [version number].

Option 3
• Click on Start in the Windows task bar.
• Select Settings.
• Click on Control Panel.
• Double-click on Add/Remove Programs.
• Select Rosetta Stone [version number].
• Click Remove.

Uninstalling the Program

4. �Click Generate to generate the new  
license file.

5. �If you are working from the machine  
to be re-hosted, click Save to File. Save 
the new file to the location you selected 
during installation. 

Windows: C:\ProgramFiles\Rosetta 
Stone\Licenses.

Macintosh: Applications ➔ Rosetta 
Stone ➔ Licenses

If you are not working from the machine 
to be re-hosted, enter an email address in 
the Send to field and click Email. Copy 
the new file from the email to the machine 
to be re-hosted in the path location you 
selected during installation. 

Windows: C:\ProgramFiles\Rosetta Stone\
Licenses.

Macintosh: Applications ➔ Rosetta 
Stone ➔ Licenses

Application
The program that runs the Rosetta Stone 
language learning interface for the student. 

Language Data CD-ROM
The language information component 
of the Rosetta Stone program. This 
information is on a separate disc from 
the application. The language data can 
be stored either on the hard drive of the 
computer where the application is installed 
or on a server on the network.

License
The legal right to use a Rosetta Stone 
product. 

License Activation code (LAC)
The 16-digit code that is used to validate 
a license at activation is located inside the 
Installation Materials folder that holds the  
CD-ROMs and lists the type of license and 
number of licenses.

License file
A file in the Licenses folder that contains 
the activated license information.

Network Application CD-ROM
The disc which contains the application 
program and FLEXnet licensing software. 
This is a separate disc from the Language 
Data CD-ROM. 

Network Configuration Utility
A tool that contains the IP addresses and 
data paths needed by the client machine.

Node-Locked license
A license that authorizes use of Rosetta 
Stone products on specific machines.  

Student Management System (SMS)
A component that allows Instructors to 
control and monitor student study of 
Rosetta Stone.

Workstation
A computer where a user can access  
Rosetta Stone. 

Glossary of Terms 

To Uninstall for Macintosh 
Drag the Rosetta Stone folder into the 
trash. Be sure to throw away any aliases 
you may have created.
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